org.oasisopen.sca.annotation.Authentication Maven / Gradle / Ivy
/*
* Fabric3
* Copyright (c) 2009 Metaform Systems
*
* Fabric3 is free software: you can redistribute it and/or modify
* it under the terms of the GNU General Public License as
* published by the Free Software Foundation, either version 3 of
* the License, or (at your option) any later version, with the
* following exception:
*
* Linking this software statically or dynamically with other
* modules is making a combined work based on this software.
* Thus, the terms and conditions of the GNU General Public
* License cover the whole combination.
*
* As a special exception, the copyright holders of this software
* give you permission to link this software with independent
* modules to produce an executable, regardless of the license
* terms of these independent modules, and to copy and distribute
* the resulting executable under terms of your choice, provided
* that you also meet, for each linked independent module, the
* terms and conditions of the license of that module. An
* independent module is a module which is not derived from or
* based on this software. If you modify this software, you may
* extend this exception to your version of the software, but
* you are not obligated to do so. If you do not wish to do so,
* delete this exception statement from your version.
*
* Fabric3 is distributed in the hope that it will be useful,
* but WITHOUT ANY WARRANTY; without even the implied warranty
* of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
* See the GNU General Public License for more details.
*
* You should have received a copy of the
* GNU General Public License along with Fabric3.
* If not, see .
*
* Based on artifacts from OASIS:
*
* Copyright(C) OASIS(R) 2005,2009. All Rights Reserved.
* OASIS trademark, IPR and other policies apply.
*/
package org.oasisopen.sca.annotation;
import static java.lang.annotation.ElementType.FIELD;
import static java.lang.annotation.ElementType.METHOD;
import static java.lang.annotation.ElementType.PARAMETER;
import static java.lang.annotation.ElementType.TYPE;
import java.lang.annotation.Inherited;
import java.lang.annotation.Retention;
import static java.lang.annotation.RetentionPolicy.RUNTIME;
import java.lang.annotation.Target;
import static org.oasisopen.sca.Constants.SCA_PREFIX;
/**
* The @Authentication annotation is used to indicate that the invocation requires authentication.
*
* @version $Rev: 7249 $ $Date: 2009-07-03 17:23:49 +0200 (Fri, 03 Jul 2009) $
*/
@Inherited
@Target({TYPE, FIELD, METHOD, PARAMETER})
@Retention(RUNTIME)
@Intent(Authentication.AUTHENTICATION)
public @interface Authentication {
String AUTHENTICATION = SCA_PREFIX + "authentication";
String AUTHENTICATION_MESSAGE = AUTHENTICATION + ".message";
String AUTHENTICATION_TRANSPORT = AUTHENTICATION + ".transport";
/**
* List of authentication qualifiers (such as "message" or "transport").
*
* @return authentication qualifiers
*/
@Qualifier String[] value() default "";
}
© 2015 - 2025 Weber Informatics LLC | Privacy Policy