org.oasisopen.sca.annotation.Intent Maven / Gradle / Ivy
Go to download
Show more of this group Show more artifacts with this name
Show all versions of sca-api Show documentation
Show all versions of sca-api Show documentation
Service Component Architecture V1.1 Java API and Annotations
/*
* Fabric3
* Copyright (c) 2009 Metaform Systems
*
* Fabric3 is free software: you can redistribute it and/or modify
* it under the terms of the GNU General Public License as
* published by the Free Software Foundation, either version 3 of
* the License, or (at your option) any later version, with the
* following exception:
*
* Linking this software statically or dynamically with other
* modules is making a combined work based on this software.
* Thus, the terms and conditions of the GNU General Public
* License cover the whole combination.
*
* As a special exception, the copyright holders of this software
* give you permission to link this software with independent
* modules to produce an executable, regardless of the license
* terms of these independent modules, and to copy and distribute
* the resulting executable under terms of your choice, provided
* that you also meet, for each linked independent module, the
* terms and conditions of the license of that module. An
* independent module is a module which is not derived from or
* based on this software. If you modify this software, you may
* extend this exception to your version of the software, but
* you are not obligated to do so. If you do not wish to do so,
* delete this exception statement from your version.
*
* Fabric3 is distributed in the hope that it will be useful,
* but WITHOUT ANY WARRANTY; without even the implied warranty
* of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
* See the GNU General Public License for more details.
*
* You should have received a copy of the
* GNU General Public License along with Fabric3.
* If not, see .
*
* Based on artifacts from OASIS:
*
* Copyright(C) OASIS(R) 2005,2009. All Rights Reserved.
* OASIS trademark, IPR and other policies apply.
*/
package org.oasisopen.sca.annotation;
import static java.lang.annotation.ElementType.ANNOTATION_TYPE;
import java.lang.annotation.Retention;
import static java.lang.annotation.RetentionPolicy.RUNTIME;
import java.lang.annotation.Target;
/**
* Annotation that can be applied to annotations that describe SCA intents.
* Adding this annotation allows SCA runtimes to automatically detect user-defined intents.
*
* Applications must specify a value, a pairing of targetNamespace and localPort, or both.
* If both value and pairing are supplied they must define the same qualified name.
*
* @version $Rev: 875 $ $Date: 2007-08-27 09:23:01 -0700 (Mon, 27 Aug 2007) $
*/
@Target({ANNOTATION_TYPE})
@Retention(RUNTIME)
public @interface Intent {
/**
* The qualified name of the intent, in the form defined by
* {@link javax.xml.namespace.QName#toString() QName.toString()}.
*
* @return the qualified name of the intent
*/
public abstract String value() default "";
/**
* The XML namespace for the intent.
*
* @return the XML namespace for the intent
*/
public abstract String targetNamespace() default "";
/**
* The name of the intent within its namespace.
*
* @return name of the intent within its namespace
*/
public abstract String localPart() default "";
}
© 2015 - 2025 Weber Informatics LLC | Privacy Policy