org.osoa.sca.ServiceUnavailableException Maven / Gradle / Ivy
Go to download
Show more of this group Show more artifacts with this name
Show all versions of sca-api-r1.0 Show documentation
Show all versions of sca-api-r1.0 Show documentation
Service Component Architecture V1.0 Java API and Annotations
The newest version!
/**
* SCA4J
* Copyright (c) 2009 - 2099 Service Symphony Ltd
*
* Licensed to you under the Apache License, Version 2.0 (the "License"); you may
* not use this file except in compliance with the License. A copy of the license
* is included in this distrubtion or you may obtain a copy at
*
* http://www.opensource.org/licenses/apache2.0.php
*
* Unless required by applicable law or agreed to in writing, software distributed
* under the License is distributed on an "AS IS" BASIS, WITHOUT WARRANTIES OR
* CONDITIONS OF ANY KIND, either express or implied. See the License for the
* specific language governing permissions and limitations under the License.
*
* This project contains code licensed from the Apache Software Foundation under
* the Apache License, Version 2.0 and original code from project contributors.
*
*
* Original Codehaus Header
*
* Copyright (c) 2007 - 2008 fabric3 project contributors
*
* Licensed to you under the Apache License, Version 2.0 (the "License"); you may
* not use this file except in compliance with the License. A copy of the license
* is included in this distrubtion or you may obtain a copy at
*
* http://www.opensource.org/licenses/apache2.0.php
*
* Unless required by applicable law or agreed to in writing, software distributed
* under the License is distributed on an "AS IS" BASIS, WITHOUT WARRANTIES OR
* CONDITIONS OF ANY KIND, either express or implied. See the License for the
* specific language governing permissions and limitations under the License.
*
* This project contains code licensed from the Apache Software Foundation under
* the Apache License, Version 2.0 and original code from project contributors.
*
* Original Apache Header
*
* Copyright (c) 2005 - 2006 The Apache Software Foundation
*
* Apache Tuscany is an effort undergoing incubation at The Apache Software
* Foundation (ASF), sponsored by the Apache Web Services PMC. Incubation is
* required of all newly accepted projects until a further review indicates that
* the infrastructure, communications, and decision making process have stabilized
* in a manner consistent with other successful ASF projects. While incubation
* status is not necessarily a reflection of the completeness or stability of the
* code, it does indicate that the project has yet to be fully endorsed by the ASF.
*
* This product includes software developed by
* The Apache Software Foundation (http://www.apache.org/).
*/
/*
* Licensed to the Apache Software Foundation (ASF) under one
* or more contributor license agreements. See the NOTICE file
* distributed with this work for additional information
* regarding copyright ownership. The ASF licenses this file
* to you under the Apache License, Version 2.0 (the
* "License"); you may not use this file except in compliance
* with the License. You may obtain a copy of the License at
*
* http://www.apache.org/licenses/LICENSE-2.0
*
* Unless required by applicable law or agreed to in writing,
* software distributed under the License is distributed on an
* "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
* KIND, either express or implied. See the License for the
* specific language governing permissions and limitations
* under the License.
*/
package org.osoa.sca;
/**
* Exception used to indicate that a runtime exception occurred during the invocation of and external service.
*
* @version $Rev: 1 $ $Date: 2007-05-14 18:40:37 +0100 (Mon, 14 May 2007) $
*/
public class ServiceUnavailableException extends ServiceRuntimeException {
private static final long serialVersionUID = -5869397223249401047L;
/**
* Constructs a new ServiceUnavailableException.
*/
public ServiceUnavailableException() {
super((Throwable) null);
}
/**
* Constructs a new ServiceUnavailableException with the specified detail message.
*
* @param message The detail message (which is saved to later retrieval by the getMessage() method).
*/
public ServiceUnavailableException(String message) {
super(message);
}
/**
* Constructs a new ServiceUnavailableException with the specified cause.
*
* @param cause The cause (which is saved to later retrieval by the getCause() method).
*/
public ServiceUnavailableException(Throwable cause) {
super(cause);
}
/**
* Constructs a new ServiceUnavailableException with the specified detail message and cause.
*
* @param message The message (which is saved to later retrieval by the getMessage() method).
* @param cause The cause (which is saved to later retrieval by the getCause() method).
*/
public ServiceUnavailableException(String message, Throwable cause) {
super(message, cause);
}
}
© 2015 - 2025 Weber Informatics LLC | Privacy Policy