org.osoa.sca.annotations.Confidentiality Maven / Gradle / Ivy
Go to download
Show more of this group Show more artifacts with this name
Show all versions of sca-api-r1.0 Show documentation
Show all versions of sca-api-r1.0 Show documentation
Service Component Architecture V1.0 Java API and Annotations
The newest version!
/**
* SCA4J
* Copyright (c) 2009 - 2099 Service Symphony Ltd
*
* Licensed to you under the Apache License, Version 2.0 (the "License"); you may
* not use this file except in compliance with the License. A copy of the license
* is included in this distrubtion or you may obtain a copy at
*
* http://www.opensource.org/licenses/apache2.0.php
*
* Unless required by applicable law or agreed to in writing, software distributed
* under the License is distributed on an "AS IS" BASIS, WITHOUT WARRANTIES OR
* CONDITIONS OF ANY KIND, either express or implied. See the License for the
* specific language governing permissions and limitations under the License.
*
* This project contains code licensed from the Apache Software Foundation under
* the Apache License, Version 2.0 and original code from project contributors.
*
*
* Original Codehaus Header
*
* Copyright (c) 2007 - 2008 fabric3 project contributors
*
* Licensed to you under the Apache License, Version 2.0 (the "License"); you may
* not use this file except in compliance with the License. A copy of the license
* is included in this distrubtion or you may obtain a copy at
*
* http://www.opensource.org/licenses/apache2.0.php
*
* Unless required by applicable law or agreed to in writing, software distributed
* under the License is distributed on an "AS IS" BASIS, WITHOUT WARRANTIES OR
* CONDITIONS OF ANY KIND, either express or implied. See the License for the
* specific language governing permissions and limitations under the License.
*
* This project contains code licensed from the Apache Software Foundation under
* the Apache License, Version 2.0 and original code from project contributors.
*
* Original Apache Header
*
* Copyright (c) 2005 - 2006 The Apache Software Foundation
*
* Apache Tuscany is an effort undergoing incubation at The Apache Software
* Foundation (ASF), sponsored by the Apache Web Services PMC. Incubation is
* required of all newly accepted projects until a further review indicates that
* the infrastructure, communications, and decision making process have stabilized
* in a manner consistent with other successful ASF projects. While incubation
* status is not necessarily a reflection of the completeness or stability of the
* code, it does indicate that the project has yet to be fully endorsed by the ASF.
*
* This product includes software developed by
* The Apache Software Foundation (http://www.apache.org/).
*/
package org.osoa.sca.annotations;
import static java.lang.annotation.ElementType.FIELD;
import static java.lang.annotation.ElementType.METHOD;
import static java.lang.annotation.ElementType.PARAMETER;
import static java.lang.annotation.ElementType.TYPE;
import java.lang.annotation.Inherited;
import java.lang.annotation.Retention;
import static java.lang.annotation.RetentionPolicy.RUNTIME;
import java.lang.annotation.Target;
import static org.osoa.sca.Constants.SCA_PREFIX;
/**
* Annotation denoting the intent that service operations require confidentiality.
*
* Applied to the injection site (field, method or constructor parameter) for a reference,
* it indicates that all invocations through that reference require confidentiality.
*
* Applied to a interface method on a service contract, it indicates that all invocations
* of that service operation require confidentiality; applied to the type of a service contract,
* it indicates that all service operations on that interface require confidentiality.
*
* Applied to a method on an implementation class, it indicates that all invocations that
* are dispatched to that implementation method (through any service) require confidentiality.
* Applied to a interface implemented by an implementation class, it indicates that all
* invocations that are dispatched to the implementation method for that interface operation
* require confidentiality.
*
* Applied to an implementation class, it indicates that all invocations of that implementation
* and that all invocations made by that implementation require confidentiality.
*
* @version $Rev: 1 $ $Date: 2007-05-14 18:40:37 +0100 (Mon, 14 May 2007) $
*/
@Inherited
@Target({TYPE, FIELD, METHOD, PARAMETER})
@Retention(RUNTIME)
@Intent(Confidentiality.CONFIDENTIALITY)
public @interface Confidentiality {
String CONFIDENTIALITY = SCA_PREFIX + "confidentiality";
String CONFIDENTIALITY_MESSAGE = CONFIDENTIALITY + ".message";
String CONFIDENTIALITY_TRANSPORT = CONFIDENTIALITY + ".transport";
/**
* List of confidentiality qualifiers (such as "message" or "transport").
*
* @return confidentiality qualifiers
*/
@Qualifier
String[] value() default "";
}
© 2015 - 2025 Weber Informatics LLC | Privacy Policy