javax.ejb.ConcurrencyManagement Maven / Gradle / Ivy
Go to download
Show more of this group Show more artifacts with this name
Show all versions of jboss-javaee-all-8.0
Show all versions of jboss-javaee-all-8.0
Combine jar files which includes all Java EE 8 Spec APIs
The newest version!
package javax.ejb;
import static java.lang.annotation.ElementType.TYPE;
import static java.lang.annotation.RetentionPolicy.RUNTIME;
import static javax.ejb.ConcurrencyManagementType.CONTAINER;
import java.lang.annotation.Retention;
import java.lang.annotation.Target;
/**
* Declares a Singleton bean's concurrency management type.
*
* @author Carlo de Wolf
* @version $Revision$
* @since 3.1
*/
@Target(TYPE)
@Retention(RUNTIME)
public @interface ConcurrencyManagement {
ConcurrencyManagementType value() default CONTAINER;
}
© 2015 - 2025 Weber Informatics LLC | Privacy Policy