javax.ejb.FinderException Maven / Gradle / Ivy
Go to download
Show more of this group Show more artifacts with this name
Show all versions of jboss-javaee-all-8.0
Show all versions of jboss-javaee-all-8.0
Combine jar files which includes all Java EE 8 Spec APIs
The newest version!
package javax.ejb;
/**
* The FinderException exception must be included in the throws clause
* of every findMETHOD(...) method of an entity Bean's home interface.
*
* The exception is used as a standard application-level exception to,
* report a failure to find the requested EJB object(s).
*/
public class FinderException extends Exception {
/**
* Constructs an FinderException with no detail message.
*/
public FinderException() {
super();
}
/**
* Constructs an FinderException with the specified detail message.
*
* @param message The detailed message.
*/
public FinderException(String message) {
super(message);
}
}
© 2015 - 2025 Weber Informatics LLC | Privacy Policy