
javax.ejb.ObjectNotFoundException Maven / Gradle / Ivy
Go to download
Show more of this group Show more artifacts with this name
Show all versions of jboss-javaee-all-8.0
Show all versions of jboss-javaee-all-8.0
Combine jar files which includes all Java EE 8 Spec APIs
The newest version!
package javax.ejb;
/**
* The ObjectNotFoundException exception is thrown by a finder method
* to indicate that the specified EJB object does not exist.
*
* Only the finder methods that are declared to return a single EJB object
* use this exception. This exception should not be thrown by finder methods
* that return a collection of EJB objects (they should return an empty collection
* instead).
*/
public class ObjectNotFoundException extends FinderException {
/**
* Constructs an ObjectNotFoundException with no detail message.
*/
public ObjectNotFoundException() {
super();
}
/**
* Constructs an ObjectNotFoundException with the specified detail message.
*
* @param message - The detailed message.
*/
public ObjectNotFoundException(String message) {
super(message);
}
}
© 2015 - 2025 Weber Informatics LLC | Privacy Policy