
javax.ejb.TimedObject Maven / Gradle / Ivy
Go to download
Show more of this group Show more artifacts with this name
Show all versions of jboss-javaee-all-8.0
Show all versions of jboss-javaee-all-8.0
Combine jar files which includes all Java EE 8 Spec APIs
The newest version!
package javax.ejb;
/**
* The TimedObject interface contains the callback method that is used
* to deliver timer expiration notifications. It is implemented by an
* entity bean or stateless session bean or message-driven bean class.
**/
public interface TimedObject {
/**
* Invoked by the EJB container upon timer expiration.
*
* @param timer Timer whose expiration caused this notification
**/
public void ejbTimeout( Timer timer );
}
© 2015 - 2025 Weber Informatics LLC | Privacy Policy