javax.ejb.TransactionAttribute Maven / Gradle / Ivy
Go to download
Show more of this group Show more artifacts with this name
Show all versions of jboss-javaee-all-8.0
Show all versions of jboss-javaee-all-8.0
Combine jar files which includes all Java EE 8 Spec APIs
The newest version!
package javax.ejb;
import java.lang.annotation.ElementType;
import java.lang.annotation.Retention;
import java.lang.annotation.RetentionPolicy;
import java.lang.annotation.Target;
/**
* The TransactionManagement annotation specifies the transaction management
* demarcation type of a session bean or message-driven bean.
*
* @author Bill Burke
* @version $Revision$
*/
@Target({ElementType.METHOD, ElementType.TYPE})
@Retention(RetentionPolicy.RUNTIME)
public @interface TransactionAttribute
{
TransactionAttributeType value() default TransactionAttributeType.REQUIRED;
}
© 2015 - 2025 Weber Informatics LLC | Privacy Policy