javax.ejb.TransactionRolledbackLocalException Maven / Gradle / Ivy
Go to download
Show more of this group Show more artifacts with this name
Show all versions of jboss-javaee-all-8.0
Show all versions of jboss-javaee-all-8.0
Combine jar files which includes all Java EE 8 Spec APIs
The newest version!
package javax.ejb;
/**
* This exception indicates that the transaction associated with processing
* of the request has been rolled back, or marked to roll back. Thus the
* requested operation either could not be performed or was not performed
* because further computation on behalf of the transaction would be fruitless.
*/
public class TransactionRolledbackLocalException extends EJBException {
/**
* Constructs a TransactionRolledbackLocalException with no detail message.
*/
public TransactionRolledbackLocalException() {
super();
}
/**
* Constructs a TransactionRolledbackLocalException with the specified detailed message.
*
* @param message - The detailed message.
*/
public TransactionRolledbackLocalException(String message) {
super(message);
}
/**
* Constructs a TransactionRolledbackLocalException with the specified detail
* message and a nested exception.
*
* @param message - The detailed message.
* @param ex - The originally thrown exception.
*/
public TransactionRolledbackLocalException(String message,Exception ex) {
super(message,ex);
}
}
© 2015 - 2025 Weber Informatics LLC | Privacy Policy