All Downloads are FREE. Search and download functionalities are using the official Maven repository.

javax.ejb.spi.EJBContainerProvider Maven / Gradle / Ivy

The newest version!
package javax.ejb.spi;

import java.util.Map;

import javax.ejb.EJBException;
import javax.ejb.embeddable.EJBContainer;

/**
 * The EJBContainerProvider SPI is used by the embeddable container bootstrap class to
 * initialize a suitable embeddable container. 
 * 
 * @author Carlo de Wolf
 * @version $Revision$
 * @since 3.1
 */
public interface EJBContainerProvider
{
   /**
    * Called by the embeddable container bootstrap process to find a suitable embeddable container
    * implementation. An embeddable container provider may deem itself as appropriate for the
    * embeddable application if any of the following are true : 
    * 
    *
  • The javax.ejb.embeddable.provider property was included in the Map passed to createEJBContainer * and the value of the property is the provider's implementation class.
  • *
  • No javax.ejb.embeddable.provider property was specified.
  • *
* If a provider does not qualify as the provider for the embeddable application, it must return null. * * @param properties * @return EJBContainer instance or null * @throws EJBException */ EJBContainer createEJBContainer(Map properties) throws EJBException; }




© 2015 - 2025 Weber Informatics LLC | Privacy Policy