javax.enterprise.concurrent.ContextService Maven / Gradle / Ivy
Go to download
Show more of this group Show more artifacts with this name
Show all versions of jboss-javaee-all-8.0
Show all versions of jboss-javaee-all-8.0
Combine jar files which includes all Java EE 8 Spec APIs
The newest version!
package javax.enterprise.concurrent;
import java.util.Map;
/**
*/
public interface ContextService {
Object createContextualProxy(Object instance, Class>... interfaces) throws IllegalArgumentException;
Object createContextualProxy(Object instance, Map executionProperties, Class>... interfaces) throws IllegalArgumentException;
T createContextualProxy(T instance, Class _interface) throws IllegalArgumentException;
T createContextualProxy(T instance, Map executionProperties, Class _interface) throws IllegalArgumentException;
Map getExecutionProperties(Object contextualProxy) throws IllegalArgumentException;
}
© 2015 - 2025 Weber Informatics LLC | Privacy Policy