All Downloads are FREE. Search and download functionalities are using the official Maven repository.

javax.enterprise.concurrent.ContextService Maven / Gradle / Ivy

The newest version!
package javax.enterprise.concurrent;

import java.util.Map;

/**
 */
public interface ContextService {

    Object createContextualProxy(Object instance, Class... interfaces) throws IllegalArgumentException;

    Object createContextualProxy(Object instance, Map executionProperties, Class... interfaces) throws IllegalArgumentException;

     T createContextualProxy(T instance, Class _interface) throws IllegalArgumentException;

     T createContextualProxy(T instance, Map executionProperties, Class _interface) throws IllegalArgumentException;

    Map getExecutionProperties(Object contextualProxy) throws IllegalArgumentException;

}




© 2015 - 2025 Weber Informatics LLC | Privacy Policy