
javax.enterprise.concurrent.ManagedTask Maven / Gradle / Ivy
Go to download
Show more of this group Show more artifacts with this name
Show all versions of jboss-javaee-all-8.0
Show all versions of jboss-javaee-all-8.0
Combine jar files which includes all Java EE 8 Spec APIs
The newest version!
package javax.enterprise.concurrent;
import java.util.Locale;
import java.util.Map;
/**
*/
public interface ManagedTask {
String IDENTITY_NAME = "javax.enterprise.concurrent.IDENTITY_NAME";
String LONGRUNNING_HINT = "javax.enterprise.concurrent.LONGRUNNING_HINT";
String SUSPEND = "SUSPEND";
String TRANSACTION = "javax.enterprise.concurrent.TRANSACTION";
String USE_TRANSACTION_OF_EXECUTION_THREAD = "USE_TRANSACTION_OF_EXECUTION_THREAD";
Map getExecutionProperties();
ManagedTaskListener getManagedTaskListener();
}
© 2015 - 2025 Weber Informatics LLC | Privacy Policy