javax.faces.component.behavior.ClientBehaviorHint Maven / Gradle / Ivy
Go to download
Show more of this group Show more artifacts with this name
Show all versions of jboss-javaee-all-8.0
Show all versions of jboss-javaee-all-8.0
Combine jar files which includes all Java EE 8 Spec APIs
The newest version!
/*
* Copyright (c) 1997, 2018 Oracle and/or its affiliates. All rights reserved.
*
* This program and the accompanying materials are made available under the
* terms of the Eclipse Public License v. 2.0, which is available at
* http://www.eclipse.org/legal/epl-2.0.
*
* This Source Code may also be made available under the following Secondary
* Licenses when the conditions for such availability set forth in the
* Eclipse Public License v. 2.0 are satisfied: GNU General Public License,
* version 2 with the GNU Classpath Exception, which is available at
* https://www.gnu.org/software/classpath/license.html.
*
* SPDX-License-Identifier: EPL-2.0 OR GPL-2.0 WITH Classpath-exception-2.0
*/
package javax.faces.component.behavior;
/**
* An enum that specifies hints that describes
* the behavior of ClientBehavior implementations.
*
* @see ClientBehavior#getHints ClientBehavior.getHints()
*
* @since 2.0
*/
public enum ClientBehaviorHint {
/**
* Hint that indicates that ClientBehavior implementation posts back to the
* server. Renderers that normally attach postback-related scripts
* may choose to omit such scripts when a submitting ClientBehavior is
* present.
*/
SUBMITTING
}
© 2015 - 2025 Weber Informatics LLC | Privacy Policy