javax.interceptor.ExcludeClassInterceptors Maven / Gradle / Ivy
Go to download
Show more of this group Show more artifacts with this name
Show all versions of jboss-javaee-all-8.0
Show all versions of jboss-javaee-all-8.0
Combine jar files which includes all Java EE 8 Spec APIs
The newest version!
package javax.interceptor;
import static java.lang.annotation.ElementType.CONSTRUCTOR;
import static java.lang.annotation.ElementType.METHOD;
import static java.lang.annotation.RetentionPolicy.RUNTIME;
import java.lang.annotation.Retention;
import java.lang.annotation.Target;
/**
* Exclude the invocation of class-level interceptors for a method. This annotation applies to a method
* that would otherwise be subject to interception.
*/
@Target({ METHOD, CONSTRUCTOR })
@Retention(RUNTIME)
public @interface ExcludeClassInterceptors {}
© 2015 - 2025 Weber Informatics LLC | Privacy Policy