javax.management.j2ee.statistics.JCAConnectionStats Maven / Gradle / Ivy
Go to download
Show more of this group Show more artifacts with this name
Show all versions of jboss-javaee-all-8.0
Show all versions of jboss-javaee-all-8.0
Combine jar files which includes all Java EE 8 Spec APIs
The newest version!
/*
* JBoss, Home of Professional Open Source.
* Copyright 2011, Red Hat Middleware LLC, and individual contributors
* as indicated by the @author tags. See the copyright.txt file in the
* distribution for a full listing of individual contributors.
*
* This is free software; you can redistribute it and/or modify it
* under the terms of the GNU Lesser General Public License as
* published by the Free Software Foundation; either version 2.1 of
* the License, or (at your option) any later version.
*
* This software is distributed in the hope that it will be useful,
* but WITHOUT ANY WARRANTY; without even the implied warranty of
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
* Lesser General Public License for more details.
*
* You should have received a copy of the GNU Lesser General Public
* License along with this software; if not, write to the Free
* Software Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA
* 02110-1301 USA, or see the FSF site: http://www.fsf.org.
*/
package javax.management.j2ee.statistics;
/**
* Specifies the statistics provided by a JCA connection
*
* @author [email protected]
*/
public interface JCAConnectionStats extends Stats
{
/**
* Returns the associated JCAConnectionFactory OBJECT_NAME
*
* @return String the OBJECT_NAME of the managed object that identifies the connection factory for this connection getManagedConnectionFactory
*/
public String getConnectionFactory();
/**
* Returns the associated JCAManagedConnectionFactory OBJECT_NAME
*
* @return String the OBJECT_NAME of the managed object that identifies the managed connection factory for this connection getWaitTime
*/
public String getManagedConnectionFactory();
/**
* Returns the time spent waiting for a connection to be available
*/
public TimeStatistic getWaitTime();
/**
* Returns the time spent using a connection
*/
public TimeStatistic getUseTime();
}
© 2015 - 2025 Weber Informatics LLC | Privacy Policy