javax.security.auth.message.AuthException Maven / Gradle / Ivy
Go to download
Show more of this group Show more artifacts with this name
Show all versions of jboss-javaee-all-8.0
Show all versions of jboss-javaee-all-8.0
Combine jar files which includes all Java EE 8 Spec APIs
The newest version!
package javax.security.auth.message;
//$Id$
import javax.security.auth.login.LoginException;
/**
* A generic authentication exception.
* @see LoginException
* @author Anil [email protected]
* @author Charlie Lai, Ron Monzillo (Javadoc for JSR-196)
* @since Dec 5, 2005
*/
public class AuthException extends LoginException
{
/** The serialVersionUID */
private static final long serialVersionUID = -1424234495120552796L;
/**
* Constructs an AuthException with no detail message.
* A detail message is a String that describes this particular exception.
*/
public AuthException()
{
super();
}
/**
* Constructs an AuthException with the specified detail message. A detail
* message is a String that describes this particular exception.
*
* @param msg the detail message.
*/
public AuthException(String msg)
{
super(msg);
}
}
© 2015 - 2025 Weber Informatics LLC | Privacy Policy