All Downloads are FREE. Search and download functionalities are using the official Maven repository.

javax.security.auth.message.callback.TrustStoreCallback Maven / Gradle / Ivy

The newest version!
package javax.security.auth.message.callback;

import javax.security.auth.callback.Callback;
import java.security.KeyStore;

//$Id$

/**
 *  

Callback for trusted certificate KeyStore.

* *

A trusted certificate KeyStore may be used to determine whether a given certificate chain can be trusted.

* * @author Anil Saldhana * @author Charlie Lai, Ron Monzillo (Javadoc for JSR-196) * @since May 11, 2006 * @version $Revision$ */ public class TrustStoreCallback implements Callback { private KeyStore trustStore; /** *

Create a new TrustStoreCallback.

*/ public TrustStoreCallback() { } /** *

Used by the TrustStore user to obtain the TrustStore set within the Callback.

* * @return The trusted certificate KeyStore. The KeyStore is guaranteed to already be loaded. */ public KeyStore getTrustStore() { return trustStore; } /** *

Used by the CallbackHandler to set the trusted certificate keystore within the Callback.

* * @param trustStore The trusted certificate KeyStore, which must already be loaded. */ public void setTrustStore(KeyStore trustStore) { this.trustStore = trustStore; } }




© 2015 - 2025 Weber Informatics LLC | Privacy Policy