All Downloads are FREE. Search and download functionalities are using the official Maven repository.

javax.security.auth.message.config.AuthConfig Maven / Gradle / Ivy

The newest version!
package javax.security.auth.message.config;

import javax.security.auth.message.MessageInfo;

//$Id$

/**
 *  

This interface defines the common functionality implemented by Authentication context configuration objects.

* * @author Anil Saldhana * @author Charlie Lai, Ron Monzillo (Javadoc for JSR-196) * @since May 12, 2006 * @version $Revision$ * @see ClientAuthContext * @see ServerAuthContext */ public interface AuthConfig { /** *

Get the application context identifier of this authentication context configuration object.

* * @return The String identifying the application context of this configuration * object or null if the configuration object pertains to an unspecified * application context. */ String getAppContext(); /** *

Get the authentication context identifier corresponding to the request and response objects encapsulated in * messageInfo.

* * @param messageInfo A contextual Object that encapsulates the client request and server response objects. * * @return The authentication context identifier corresponding to the encapsulated request and response * objects, or null. * * @throws IllegalArgumentException If the type of the message objects incorporated in * messageInfo are not compatible with the message types supported by this * authentication context configuration object. */ String getAuthContextID(MessageInfo messageInfo); /** *

Get the message layer name of this authentication context configuration object.

* * @return The message layer name of this configuration object, or null if the * configuration object pertains to an unspecified message layer. */ String getMessageLayer(); /** *

Used to determine whether the authentication context configuration object encapsulates any protected * authentication contexts.

* * @return True if the configuration object encapsulates at least one protected authentication context. * Otherwise, this method returns false. */ boolean isProtected(); /** *

Causes a dynamic authentication context configuration object to update the internal state that it uses to * process calls to its getAuthContext method.

* * @throws SecurityException If the caller does not have permission to refresh the configuration object, * or if an error occurred during the update. */ void refresh(); }




© 2015 - 2025 Weber Informatics LLC | Privacy Policy