All Downloads are FREE. Search and download functionalities are using the official Maven repository.

javax.transaction.HeuristicMixedException Maven / Gradle / Ivy

The newest version!
package javax.transaction;

/**
 *  This exception is thrown to report that a heuristic decision was made and
 *  that some some parts of the transaction have been committed while other
 *  parts have been rolled back. 
 *
 *  @version $Revision$
 */
public class HeuristicMixedException extends Exception
{

    /**
     *  Creates a new HeuristicMixedException without a
     *  detail message.
     */
    public HeuristicMixedException()
    {
    }

    /**
     *  Constructs an HeuristicMixedException with the
     *  specified detail message.
     *
     *  @param msg the detail message.
     */
    public HeuristicMixedException(String msg)
    {
        super(msg);
    }
}




© 2015 - 2025 Weber Informatics LLC | Privacy Policy