All Downloads are FREE. Search and download functionalities are using the official Maven repository.

javax.transaction.NotSupportedException Maven / Gradle / Ivy

The newest version!
package javax.transaction;

/**
 *  The NotSupportedException exception indicates that an operation is not
 *  supported.
 *
 *  For example, the {@link TransactionManager#begin()} and 
 *  {@link UserTransaction#begin()} methods throw this exception if the
 *  calling thread is already associated with a transaction, and nested
 *  transactions are not supported.
 *
 *  @version $Revision$
 */
public class NotSupportedException extends Exception
{

    /**
     *  Creates a new NotSupportedException without a
     *  detail message.
     */
    public NotSupportedException()
    {
    }

    /**
     *  Constructs an NotSupportedException with the specified
     *  detail message.
     *
     *  @param msg the detail message.
     */
    public NotSupportedException(String msg)
    {
        super(msg);
    }
}




© 2015 - 2025 Weber Informatics LLC | Privacy Policy