All Downloads are FREE. Search and download functionalities are using the official Maven repository.

javax.transaction.SystemException Maven / Gradle / Ivy

The newest version!
package javax.transaction;

/**
 *  This exception is thrown to indicate that the transaction manager has
 *  encountered an unexpected error condition that prevents future
 *  transaction services from proceeding. 
 *
 *  @version $Revision$
 */
public class SystemException extends Exception
{
    /**
     *  The error code of this exception. Values of this field are not
     *  specified by JTA.
     */
    public int errorCode;

    /**
     *  Creates a new SystemException without a detail message.
     */
    public SystemException()
    {
    }

    /**
     *  Constructs an SystemException with the specified
     *  detail message.
     *
     *  @param msg the detail message.
     */
    public SystemException(String msg)
    {
        super(msg);
    }

    /**
     *  Constructs an SystemException with the specified
     *  detail message.
     *
     *  @param errcode the error code for the exception
     */
    public SystemException(int errcode)
    {
        this.errorCode = errcode;
    }
}




© 2015 - 2025 Weber Informatics LLC | Privacy Policy