All Downloads are FREE. Search and download functionalities are using the official Maven repository.

javax.transaction.TransactionScoped Maven / Gradle / Ivy

The newest version!
package javax.transaction;

import java.lang.annotation.ElementType;
import java.lang.annotation.Retention;
import java.lang.annotation.Target;

import javax.enterprise.context.NormalScope;

  /**
   * Annotation used to indicate a bean is to be scoped to the current active
   * JTA transaction.
   *
   * @since JTA1.2
   *
   **/
@Retention(java.lang.annotation.RetentionPolicy.RUNTIME)
@Target({ElementType.TYPE, ElementType.METHOD, ElementType.FIELD})
@NormalScope(passivating=true)
public @interface TransactionScoped {
}




© 2015 - 2025 Weber Informatics LLC | Privacy Policy