
javax.validation.ReportAsSingleViolation Maven / Gradle / Ivy
Go to download
Show more of this group Show more artifacts with this name
Show all versions of jboss-javaee-all-8.0
Show all versions of jboss-javaee-all-8.0
Combine jar files which includes all Java EE 8 Spec APIs
The newest version!
/*
* Bean Validation API
*
* License: Apache License, Version 2.0
* See the license.txt file in the root directory or .
*/
package javax.validation;
import java.lang.annotation.Documented;
import java.lang.annotation.Retention;
import java.lang.annotation.Target;
import static java.lang.annotation.ElementType.ANNOTATION_TYPE;
import static java.lang.annotation.RetentionPolicy.RUNTIME;
/**
* A constraint annotation hosting this annotation will return the
* composed annotation error report if any of the composing annotations fail.
* The error reports of each individual composing constraint are ignored.
*
* Note: Evaluation of composed constraints stops on the first validation
* error in case the composing constraint is annotated with
* {@code @ReportAsSingleViolation}.
*
* @author Emmanuel Bernard
*/
@Target({ ANNOTATION_TYPE })
@Retention(RUNTIME)
@Documented
public @interface ReportAsSingleViolation {
}
© 2015 - 2025 Weber Informatics LLC | Privacy Policy