javax.validation.ValidationProviderResolver Maven / Gradle / Ivy
Go to download
Show more of this group Show more artifacts with this name
Show all versions of jboss-javaee-all-8.0
Show all versions of jboss-javaee-all-8.0
Combine jar files which includes all Java EE 8 Spec APIs
The newest version!
/*
* Bean Validation API
*
* License: Apache License, Version 2.0
* See the license.txt file in the root directory or .
*/
package javax.validation;
import java.util.List;
import javax.validation.spi.ValidationProvider;
/**
* Determines the list of Bean Validation providers available in the runtime environment
*
* Bean Validation providers are identified by the presence of
* {@code META-INF/services/javax.validation.spi.ValidationProvider}
* files following the Service Provider pattern described
* here.
*
* Each {@code META-INF/services/javax.validation.spi.ValidationProvider} file contains the
* list of {@link ValidationProvider} implementations each of them representing a provider.
*
* Implementations must be thread-safe.
*
* @author Emmanuel Bernard
*/
public interface ValidationProviderResolver {
/**
* Returns a list of {@link ValidationProvider} available in the runtime environment.
*
* @return list of validation providers
*/
List> getValidationProviders();
}
© 2015 - 2025 Weber Informatics LLC | Privacy Policy