javax.validation.metadata.CrossParameterDescriptor Maven / Gradle / Ivy
Go to download
Show more of this group Show more artifacts with this name
Show all versions of jboss-javaee-all-8.0
Show all versions of jboss-javaee-all-8.0
Combine jar files which includes all Java EE 8 Spec APIs
The newest version!
/*
* Bean Validation API
*
* License: Apache License, Version 2.0
* See the license.txt file in the root directory or .
*/
package javax.validation.metadata;
/**
* Describes an element holding cross-parameter constraints of a method or constructor
*
* @author Emmanuel Bernard
* @since 1.1
*/
public interface CrossParameterDescriptor extends ElementDescriptor {
/**
* @return {@code Object[].class} - the type of the parameter array
*/
@Override
Class> getElementClass();
}
© 2015 - 2025 Weber Informatics LLC | Privacy Policy