javax.xml.soap.MimeHeader Maven / Gradle / Ivy
Go to download
Show more of this group Show more artifacts with this name
Show all versions of jboss-javaee-all-8.0
Show all versions of jboss-javaee-all-8.0
Combine jar files which includes all Java EE 8 Spec APIs
The newest version!
/*
* $Id: MimeHeader.java,v 1.4 2006/03/30 00:59:38 ofung Exp $
* $Revision: 1.4 $
* $Date: 2006/03/30 00:59:38 $
*/
/*
* The contents of this file are subject to the terms
* of the Common Development and Distribution License
* (the License). You may not use this file except in
* compliance with the License.
*
* You can obtain a copy of the license at
* https://glassfish.dev.java.net/public/CDDLv1.0.html.
* See the License for the specific language governing
* permissions and limitations under the License.
*
* When distributing Covered Code, include this CDDL
* Header Notice in each file and include the License file
* at https://glassfish.dev.java.net/public/CDDLv1.0.html.
* If applicable, add the following below the CDDL Header,
* with the fields enclosed by brackets [] replaced by
* you own identifying information:
* "Portions Copyrighted [year] [name of copyright owner]"
*
* Copyright 2006 Sun Microsystems Inc. All Rights Reserved
*/
package javax.xml.soap;
/**
* An object that stores a MIME header name and its value. One or more
* MimeHeader
objects may be contained in a MimeHeaders
* object.
*
* @see MimeHeaders
*/
public class MimeHeader {
private String name;
private String value;
/**
* Constructs a MimeHeader
object initialized with the given
* name and value.
*
* @param name a String
giving the name of the header
* @param value a String
giving the value of the header
*/
public MimeHeader(String name, String value) {
this.name = name;
this.value = value;
}
/**
* Returns the name of this MimeHeader
object.
*
* @return the name of the header as a String
*/
public String getName() {
return name;
}
/**
* Returns the value of this MimeHeader
object.
*
* @return the value of the header as a String
*/
public String getValue() {
return value;
}
}
© 2015 - 2025 Weber Informatics LLC | Privacy Policy