
javax.xml.soap.Node Maven / Gradle / Ivy
Go to download
Show more of this group Show more artifacts with this name
Show all versions of jboss-javaee-all-8.0
Show all versions of jboss-javaee-all-8.0
Combine jar files which includes all Java EE 8 Spec APIs
The newest version!
/*
* $Id: Node.java,v 1.14 2006/03/30 00:59:39 ofung Exp $
* $Revision: 1.14 $
* $Date: 2006/03/30 00:59:39 $
*/
/*
* The contents of this file are subject to the terms
* of the Common Development and Distribution License
* (the License). You may not use this file except in
* compliance with the License.
*
* You can obtain a copy of the license at
* https://glassfish.dev.java.net/public/CDDLv1.0.html.
* See the License for the specific language governing
* permissions and limitations under the License.
*
* When distributing Covered Code, include this CDDL
* Header Notice in each file and include the License file
* at https://glassfish.dev.java.net/public/CDDLv1.0.html.
* If applicable, add the following below the CDDL Header,
* with the fields enclosed by brackets [] replaced by
* you own identifying information:
* "Portions Copyrighted [year] [name of copyright owner]"
*
* Copyright 2006 Sun Microsystems Inc. All Rights Reserved
*/
package javax.xml.soap;
/**
* A representation of a node (element) in an XML document.
* This interface extnends the standard DOM Node interface with methods for
* getting and setting the value of a node, for
* getting and setting the parent of a node, and for removing a node.
*/
public interface Node extends org.w3c.dom.Node {
/**
* Returns the value of this node if this is a Text
node or the
* value of the immediate child of this node otherwise.
* If there is an immediate child of this Node
that it is a
* Text
node then it's value will be returned. If there is
* more than one Text
node then the value of the first
* Text
Node will be returned.
* Otherwise null
is returned.
*
* @return a String
with the text of this node if this is a
* Text
node or the text contained by the first
* immediate child of this Node
object that is a
* Text
object if such a child exists;
* null
otherwise.
*/
public String getValue();
/**
* If this is a Text node then this method will set its value,
* otherwise it sets the value of the immediate (Text) child of this node.
* The value of the immediate child of this node can be set only if, there is
* one child node and that node is a Text
node, or if
* there are no children in which case a child Text
node will be
* created.
*
* @exception IllegalStateException if the node is not a Text
* node and either has more than one child node or has a child
* node that is not a Text
node.
*
* @since SAAJ 1.2
*/
public void setValue(String value);
/**
* Sets the parent of this Node
object to the given
* SOAPElement
object.
*
* @param parent the SOAPElement
object to be set as
* the parent of this Node
object
*
* @exception SOAPException if there is a problem in setting the
* parent to the given element
* @see #getParentElement
*/
public void setParentElement(SOAPElement parent) throws SOAPException;
/**
* Returns the parent element of this Node
object.
* This method can throw an UnsupportedOperationException
* if the tree is not kept in memory.
*
* @return the SOAPElement
object that is the parent of
* this Node
object or null
if this
* Node
object is root
*
* @exception UnsupportedOperationException if the whole tree is not
* kept in memory
* @see #setParentElement
*/
public SOAPElement getParentElement();
/**
* Removes this Node
object from the tree.
*/
public void detachNode();
/**
* Notifies the implementation that this Node
* object is no longer being used by the application and that the
* implementation is free to reuse this object for nodes that may
* be created later.
*
* Calling the method recycleNode
implies that the method
* detachNode
has been called previously.
*/
public void recycleNode();
}
© 2015 - 2025 Weber Informatics LLC | Privacy Policy