All Downloads are FREE. Search and download functionalities are using the official Maven repository.

javax.xml.soap.Text Maven / Gradle / Ivy

The newest version!
/*
 * $Id: Text.java,v 1.4 2006/03/30 00:59:42 ofung Exp $
 * $Revision: 1.4 $
 * $Date: 2006/03/30 00:59:42 $
 */

/*
 * The contents of this file are subject to the terms
 * of the Common Development and Distribution License
 * (the License).  You may not use this file except in
 * compliance with the License.
 * 
 * You can obtain a copy of the license at
 * https://glassfish.dev.java.net/public/CDDLv1.0.html.
 * See the License for the specific language governing
 * permissions and limitations under the License.
 * 
 * When distributing Covered Code, include this CDDL
 * Header Notice in each file and include the License file
 * at https://glassfish.dev.java.net/public/CDDLv1.0.html.
 * If applicable, add the following below the CDDL Header,
 * with the fields enclosed by brackets [] replaced by
 * you own identifying information:
 * "Portions Copyrighted [year] [name of copyright owner]"
 * 
 * Copyright 2006 Sun Microsystems Inc. All Rights Reserved
 */
package javax.xml.soap;

/**
 * A representation of a node whose value is text.  A Text object
 * may represent text that is content or text that is a comment.
 *
 */
public interface Text extends Node, org.w3c.dom.Text {

    /**
     * Retrieves whether this Text object represents a comment.
     *
     * @return true if this Text object is a
     *         comment; false otherwise
     */
    public boolean isComment();
}




© 2015 - 2025 Weber Informatics LLC | Privacy Policy