javax.xml.ws.handler.Handler Maven / Gradle / Ivy
Go to download
Show more of this group Show more artifacts with this name
Show all versions of jboss-javaee-all-8.0
Show all versions of jboss-javaee-all-8.0
Combine jar files which includes all Java EE 8 Spec APIs
The newest version!
/*
* DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS HEADER.
*
* Copyright (c) 2005-2017 Oracle and/or its affiliates. All rights reserved.
*
* The contents of this file are subject to the terms of either the GNU
* General Public License Version 2 only ("GPL") or the Common Development
* and Distribution License("CDDL") (collectively, the "License"). You
* may not use this file except in compliance with the License. You can
* obtain a copy of the License at
* https://oss.oracle.com/licenses/CDDL+GPL-1.1
* or LICENSE.txt. See the License for the specific
* language governing permissions and limitations under the License.
*
* When distributing the software, include this License Header Notice in each
* file and include the License file at LICENSE.txt.
*
* GPL Classpath Exception:
* Oracle designates this particular file as subject to the "Classpath"
* exception as provided by Oracle in the GPL Version 2 section of the License
* file that accompanied this code.
*
* Modifications:
* If applicable, add the following below the License Header, with the fields
* enclosed by brackets [] replaced by your own identifying information:
* "Portions Copyright [year] [name of copyright owner]"
*
* Contributor(s):
* If you wish your version of this file to be governed by only the CDDL or
* only the GPL Version 2, indicate your decision by adding "[Contributor]
* elects to include this software in this distribution under the [CDDL or GPL
* Version 2] license." If you don't indicate a single choice of license, a
* recipient has the option to distribute your version of this file under
* either the CDDL, the GPL Version 2 or to extend the choice of license to
* its licensees as provided above. However, if you add GPL Version 2 code
* and therefore, elected the GPL Version 2 license, then the option applies
* only if the new code is made subject to such option by the copyright
* holder.
*/
package javax.xml.ws.handler;
import javax.xml.ws.ProtocolException;
/** The {@code Handler} interface
* is the base interface for JAX-WS handlers.
*
* @param message context
* @since 1.6, JAX-WS 2.0
**/
public interface Handler {
/** The {@code handleMessage} method is invoked for normal processing
* of inbound and outbound messages. Refer to the description of the handler
* framework in the JAX-WS specification for full details.
*
* @param context the message context.
* @return An indication of whether handler processing should continue for
* the current message
*
* - Return {@code true} to continue
* processing.
* - Return {@code false} to block
* processing.
*
* @throws RuntimeException Causes the JAX-WS runtime to cease
* handler processing and generate a fault.
* @throws ProtocolException Causes the JAX-WS runtime to switch to
* fault message processing.
**/
public boolean handleMessage(C context);
/** The {@code handleFault} method is invoked for fault message
* processing. Refer to the description of the handler
* framework in the JAX-WS specification for full details.
*
* @param context the message context
* @return An indication of whether handler fault processing should continue
* for the current message
*
* - Return {@code true} to continue
* processing.
* - Return {@code false} to block
* processing.
*
* @throws RuntimeException Causes the JAX-WS runtime to cease
* handler fault processing and dispatch the fault.
* @throws ProtocolException Causes the JAX-WS runtime to cease
* handler fault processing and dispatch the fault.
**/
public boolean handleFault(C context);
/**
* Called at the conclusion of a message exchange pattern just prior to
* the JAX-WS runtime dispatching a message, fault or exception. Refer to
* the description of the handler
* framework in the JAX-WS specification for full details.
*
* @param context the message context
**/
public void close(MessageContext context);
}
© 2015 - 2025 Weber Informatics LLC | Privacy Policy