org.jboss.bpm.dialect.stp.model.SequenceEdge Maven / Gradle / Ivy
The newest version!
//
// This file was generated by the JavaTM Architecture for XML Binding(JAXB) Reference Implementation, vJAXB 2.1.3 in JDK 1.6
// See http://java.sun.com/xml/jaxb
// Any modifications to this file will be lost upon recompilation of the source schema.
// Generated on: 2008.07.17 at 06:01:54 PM CEST
//
package org.jboss.bpm.dialect.stp.model;
import javax.xml.bind.annotation.XmlAccessType;
import javax.xml.bind.annotation.XmlAccessorType;
import javax.xml.bind.annotation.XmlAttribute;
import javax.xml.bind.annotation.XmlSchemaType;
import javax.xml.bind.annotation.XmlType;
/**
* Java class for SequenceEdge complex type.
*
*
The following schema fragment specifies the expected content contained within this class.
*
*
* <complexType name="SequenceEdge">
* <complexContent>
* <extension base="{http://stp.eclipse.org/bpmn}Identifiable">
* <attribute name="graph" type="{http://www.w3.org/2001/XMLSchema}anyURI" />
* <attribute name="source" type="{http://www.w3.org/2001/XMLSchema}anyURI" />
* <attribute name="target" type="{http://www.w3.org/2001/XMLSchema}anyURI" />
* <attribute name="isDefault" type="{http://www.w3.org/2001/XMLSchema}boolean" />
* <attribute name="conditionType" type="{http://stp.eclipse.org/bpmn}SequenceFlowConditionType" />
* </extension>
* </complexContent>
* </complexType>
*
*
*
*/
@XmlAccessorType(XmlAccessType.FIELD)
@XmlType(name = "SequenceEdge")
public class SequenceEdge
extends Identifiable
{
@XmlAttribute
@XmlSchemaType(name = "anyURI")
protected String graph;
@XmlAttribute
@XmlSchemaType(name = "anyURI")
protected String source;
@XmlAttribute
@XmlSchemaType(name = "anyURI")
protected String target;
@XmlAttribute
protected Boolean isDefault;
@XmlAttribute
protected SequenceFlowConditionType conditionType;
/**
* Gets the value of the graph property.
*
* @return
* possible object is
* {@link String }
*
*/
public String getGraph() {
return graph;
}
/**
* Sets the value of the graph property.
*
* @param value
* allowed object is
* {@link String }
*
*/
public void setGraph(String value) {
this.graph = value;
}
/**
* Gets the value of the source property.
*
* @return
* possible object is
* {@link String }
*
*/
public String getSource() {
return source;
}
/**
* Sets the value of the source property.
*
* @param value
* allowed object is
* {@link String }
*
*/
public void setSource(String value) {
this.source = value;
}
/**
* Gets the value of the target property.
*
* @return
* possible object is
* {@link String }
*
*/
public String getTarget() {
return target;
}
/**
* Sets the value of the target property.
*
* @param value
* allowed object is
* {@link String }
*
*/
public void setTarget(String value) {
this.target = value;
}
/**
* Gets the value of the isDefault property.
*
* @return
* possible object is
* {@link Boolean }
*
*/
public Boolean isIsDefault() {
return isDefault;
}
/**
* Sets the value of the isDefault property.
*
* @param value
* allowed object is
* {@link Boolean }
*
*/
public void setIsDefault(Boolean value) {
this.isDefault = value;
}
/**
* Gets the value of the conditionType property.
*
* @return
* possible object is
* {@link SequenceFlowConditionType }
*
*/
public SequenceFlowConditionType getConditionType() {
return conditionType;
}
/**
* Sets the value of the conditionType property.
*
* @param value
* allowed object is
* {@link SequenceFlowConditionType }
*
*/
public void setConditionType(SequenceFlowConditionType value) {
this.conditionType = value;
}
}