org.jboss.bpm.ri.client.ProcessManagerImpl Maven / Gradle / Ivy
The newest version!
/*
* JBoss, Home of Professional Open Source
* Copyright 2005, JBoss Inc., and individual contributors as indicated
* by the @authors tag. See the copyright.txt in the distribution for a
* full listing of individual contributors.
*
* This is free software; you can redistribute it and/or modify it
* under the terms of the GNU Lesser General Public License as
* published by the Free Software Foundation; either version 2.1 of
* the License, or (at your option) any later version.
*
* This software is distributed in the hope that it will be useful,
* but WITHOUT ANY WARRANTY; without even the implied warranty of
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
* Lesser General Public License for more details.
*
* You should have received a copy of the GNU Lesser General Public
* License along with this software; if not, write to the Free
* Software Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA
* 02110-1301 USA, or see the FSF site: http://www.fsf.org.
*/
package org.jboss.bpm.ri.client;
// $Id: ProcessManagerImpl.java 1982 2008-08-22 10:09:27Z [email protected] $
import java.util.Map;
import org.jboss.bpm.client.DialectHandler;
import org.jboss.bpm.client.DialectRegistry;
import org.jboss.bpm.client.ProcessManager;
import org.jboss.bpm.model.Process;
import org.jboss.bpm.ri.model.impl.ProcessImpl;
/**
* The process manager is the entry point to create, find and otherwise manage processes.
*
* @author [email protected]
* @since 18-Jun-2008
*/
public class ProcessManagerImpl extends ProcessManager
{
public void setDialectHandlers(Map dialectHandlers)
{
this.dialectHandlers = dialectHandlers;
}
public void setDialectRegistry(DialectRegistry dialectRegistry)
{
this.dialectRegistry = dialectRegistry;
}
@Override
public void registerProcess(Process proc)
{
super.registerProcess(proc);
ProcessImpl procImpl = (ProcessImpl)proc;
procImpl.register(proc);
}
@Override
public void unregisterProcess(Process proc)
{
ProcessImpl procImpl = (ProcessImpl)proc;
procImpl.unregister(proc);
super.unregisterProcess(proc);
}
}