All Downloads are FREE. Search and download functionalities are using the official Maven repository.

org.jboss.bpm.ri.model.impl.EntityImpl Maven / Gradle / Ivy

The newest version!
/*
 * JBoss, Home of Professional Open Source
 * Copyright 2005, JBoss Inc., and individual contributors as indicated
 * by the @authors tag. See the copyright.txt in the distribution for a
 * full listing of individual contributors.
 *
 * This is free software; you can redistribute it and/or modify it
 * under the terms of the GNU Lesser General Public License as
 * published by the Free Software Foundation; either version 2.1 of
 * the License, or (at your option) any later version.
 *
 * This software is distributed in the hope that it will be useful,
 * but WITHOUT ANY WARRANTY; without even the implied warranty of
 * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
 * Lesser General Public License for more details.
 *
 * You should have received a copy of the GNU Lesser General Public
 * License along with this software; if not, write to the Free
 * Software Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA
 * 02110-1301 USA, or see the FSF site: http://www.fsf.org.
 */
package org.jboss.bpm.ri.model.impl;

import javax.management.ObjectName;

import org.jboss.bpm.model.Entity;
import org.jboss.bpm.model.Role;

//$Id: EntityImpl.java 1983 2008-08-22 11:12:51Z [email protected] $

/**
 * An Entity, which is used in the definition of attributes for a @{link Participant}
 * 
 * @author [email protected]
 * @since 21-Jul-2008
 */
@SuppressWarnings("serial")
public class EntityImpl extends ParticipantImpl implements Entity
{

  public EntityImpl(ObjectName name)
  {
    super(name);
  }

  public ParticipantType getParticipantType()
  {
    return ParticipantType.Entity;
  }
  
  public ObjectName getName()
  {
    return name;
  }

  public Entity getEntityRef()
  {
    return this;
  }

  public Role getRoleRef()
  {
    return null;
  }
}




© 2015 - 2024 Weber Informatics LLC | Privacy Policy