All Downloads are FREE. Search and download functionalities are using the official Maven repository.

org.jboss.bpm.ri.model.spec.ReferenceTask Maven / Gradle / Ivy

The newest version!
/*
 * JBoss, Home of Professional Open Source
 * Copyright 2005, JBoss Inc., and individual contributors as indicated
 * by the @authors tag. See the copyright.txt in the distribution for a
 * full listing of individual contributors.
 *
 * This is free software; you can redistribute it and/or modify it
 * under the terms of the GNU Lesser General Public License as
 * published by the Free Software Foundation; either version 2.1 of
 * the License, or (at your option) any later version.
 *
 * This software is distributed in the hope that it will be useful,
 * but WITHOUT ANY WARRANTY; without even the implied warranty of
 * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
 * Lesser General Public License for more details.
 *
 * You should have received a copy of the GNU Lesser General Public
 * License along with this software; if not, write to the Free
 * Software Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA
 * 02110-1301 USA, or see the FSF site: http://www.fsf.org.
 */
package org.jboss.bpm.ri.model.spec;

import org.jboss.bpm.model.Task;

//$Id: ReferenceTask.java 1929 2008-08-19 10:48:17Z [email protected] $

/**
 * There may be times where a modeler may want to reference another activity that has been defined. If the two (or more)
 * activities share the exact same behavior, then by one referencing the other, the attributes that define the behavior only
 * have to be created once and maintained in only one location.
 * 
 * @author [email protected]
 * @since 08-Jul-2008
 */
public interface ReferenceTask extends Task
{
  /**
   * The Task being referenced MUST be identified.
   */
  Task getTaskRef();
}




© 2015 - 2024 Weber Informatics LLC | Privacy Policy