All Downloads are FREE. Search and download functionalities are using the official Maven repository.

org.jboss.bpm.ri.model.spec.TimerEventDetail Maven / Gradle / Ivy

The newest version!
/*
 * JBoss, Home of Professional Open Source
 * Copyright 2005, JBoss Inc., and individual contributors as indicated
 * by the @authors tag. See the copyright.txt in the distribution for a
 * full listing of individual contributors.
 *
 * This is free software; you can redistribute it and/or modify it
 * under the terms of the GNU Lesser General Public License as
 * published by the Free Software Foundation; either version 2.1 of
 * the License, or (at your option) any later version.
 *
 * This software is distributed in the hope that it will be useful,
 * but WITHOUT ANY WARRANTY; without even the implied warranty of
 * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
 * Lesser General Public License for more details.
 *
 * You should have received a copy of the GNU Lesser General Public
 * License along with this software; if not, write to the Free
 * Software Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA
 * 02110-1301 USA, or see the FSF site: http://www.fsf.org.
 */
package org.jboss.bpm.ri.model.spec;

import org.jboss.bpm.model.EventDetail;

//$Id: TimerEventDetail.java 1929 2008-08-19 10:48:17Z [email protected] $

/**
 * The Timer event detail 
 * 
 * @author [email protected]
 * @since 21-Jul-2008
 */
public interface TimerEventDetail extends EventDetail
{
  /**
   * If the Trigger is a Timer, then a TimeDate MAY be entered. If a TimeDate is not
   * entered, then a TimeCycle MUST be entered
   */
  TimeDateExpression getTimeDate();
  
  /**
   * If the Trigger is a Timer, then a TimeCycle MAY be entered. If a TimeCycle is
   * not entered, then a TimeDate MUST be entered
   */
  TimeDateExpression getTimeCycle();
  
}




© 2015 - 2024 Weber Informatics LLC | Privacy Policy