org.ow2.spec.testengine.ComparisonError Maven / Gradle / Ivy
/**
* OW2 Specifications
* Copyright (C) 2007 Bull S.A.S.
* Contact: [email protected]
*
* This library is free software; you can redistribute it and/or
* modify it under the terms of the GNU Lesser General Public
* License as published by the Free Software Foundation; either
* version 2.1 of the License, or any later version.
*
* This library is distributed in the hope that it will be useful,
* but WITHOUT ANY WARRANTY; without even the implied warranty of
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
* Lesser General Public License for more details.
*
* You should have received a copy of the GNU Lesser General Public
* License along with this library; if not, write to the Free Software
* Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
* USA
*
* --------------------------------------------------------------------------
* $Id: ComparisonError.java 4359 2008-12-10 10:24:40Z sauthieg $
* --------------------------------------------------------------------------
*/
package org.ow2.spec.testengine;
/**
* Represents an error report.
* @author Guillaume Sauthier
*/
public class ComparisonError {
/**
* Error message.
*/
private String message;
/**
* @param message the error message
*/
public ComparisonError(String message) {
super();
this.message = message;
}
/**
* @see java.lang.Object#toString()
*/
@Override
public String toString() {
return message;
}
}