All Downloads are FREE. Search and download functionalities are using the official Maven repository.

org.reaktivity.specification.kafka.produce.v3.partition.unknown.server.rpt Maven / Gradle / Ivy

There is a newer version: 0.172
Show newest version
#
# Copyright 2016-2020 The Reaktivity Project
#
# The Reaktivity Project licenses this file to you under the Apache License,
# version 2.0 (the "License"); you may not use this file except in compliance
# with the License. You may obtain a copy of the License at:
#
#   http://www.apache.org/licenses/LICENSE-2.0
#
# Unless required by applicable law or agreed to in writing, software
# distributed under the License is distributed on an "AS IS" BASIS, WITHOUT
# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the
# License for the specific language governing permissions and limitations
# under the License.
#

property networkAccept "nukleus://streams/kafka#0"
property networkAcceptWindow 8192

property deltaMillis 0L
property newTimestamp ${kafka:timestamp() + deltaMillis}

accept ${networkAccept}
  option nukleus:window ${networkAcceptWindow}
  option nukleus:transmission "duplex"
  option nukleus:byteorder "network"

accepted

connected

read 21                                 # size
     3s                                 # metadata
     5s                                 # v5
     (int:requestId)
     -1s                                # no client id
     1                                  # topics
       4s "test"                        #   "test" topic
     [0x00]                             # allow_auto_topic_creation

write 97                                # size
      ${requestId}
      0
      1                                 # brokers
        0xb1                                # broker id
        19s "broker1.example.com"           # host name
        9092                                # port
        -1s                                 # no rack
      9s "cluster 1"                    # cluster id
      1                                 # controller id
      1                                 # topics
        0s                                # no error
        4s "test"                         #   "test" topic
        [0x00]                            # not internal
        1                                 # partitions
          0s                                # no error
          0                                 # partition
          0xb1                              # leader
          0                                 # no replicas
          -1                                # no in-sync replicas
          0                                 # offline replicas

accepted

read nukleus:begin.ext ${proxy:beginEx()
                              .typeId(nukleus:id("proxy"))
                              .addressInet()
                                .protocol("stream")
                                .source("0.0.0.0")
                                .destination("broker1.example.com")
                                .sourcePort(0)
                                .destinationPort(9092)
                                .build()
                              .build()}

connected

read 108
     0s
     3s
     (int:requestId)
     -1s
     -1s
     [0..2]
     [0..4]
     1
     4s "test"
     1
     0
     68                                 # record set size
     0L                                 # first offset
     56                                 # length
     -1
     [0x02]
     [0..4]
     0s
     0                                  # last offset delta
     (long:timestamp)                   # first timestamp
     ${timestamp}                       # last timestamp
     -1L
     -1s
     -1
     1                                  # records
     ${kafka:varint(6)}
     [0x00]
     ${kafka:varint(0)}
     ${kafka:varint(0)}
     ${kafka:varint(-1)}
     ${kafka:varint(-1)}
     ${kafka:varint(0)}                 # headers

write 44
      ${requestId}
      1                                 # topics
      4s "test"
      1                                 # partitions
      0                                 # partition 0
      3s                                # unknown-topic-or-partition
      -1L                               # base offset
      0L                                # log append time
      0                                 # throttle




© 2015 - 2024 Weber Informatics LLC | Privacy Policy